Suzuki question - 2CoolFishing
Home  |  Contact Us  |  Advertise   |   Follow:
Go Back   2CoolFishing > General Interest Forums > Boating Forum
Register FAQ Social Groups Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 09-17-2020, 12:34 AM   #1
SKIPJACKSLAYER
Registered Users-pm+
 
Join Date: Nov 19 2013
Location: Flour Bluff
Age: 32
Posts: 1,111
Rep Power: 8603578
SKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to Pirate
Suzuki question

My buddy has a 2019 suzuki 115 hp with less than 15 hours on it. Turk and trim randomly stopped working on it. You can hear the relay clicking when trying to go up and down. Both switches on the binnacle and the cowling are doing the same thing. The digital tach is saying error code 3-7. Now I know where the trim limiter switch is, and I know how to set it with the binnacle. But is there a trim sensor somewhere I need to look for? Wondering what to look for. Batter has 12+ Volts, will start checking connections under the hood and checking voltage going to the pump itself. But I have a feeling it’s something simple
SKIPJACKSLAYER is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-17-2020, 07:31 PM   #2
pocfishin
Registered Users-pm+
 
Join Date: Jan 21 2006
Location: Seguin
Age: 59
Posts: 218
Rep Power: 1384732
pocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Piratepocfishin has been promoted to Pirate
Error code appears to be trim sensor as you suspect.

https://www.suzukioutboardforum.com/...error-code-3-7

Here is some info for a Suzuki DF70.
https://www.manualslib.com/manual/15...a.html?page=88

I ain't no mechanic. Best of luck.
pocfishin is offline   Reply With Quote Quick reply to this message
Old 09-18-2020, 09:13 AM   #3
fishinguy
Registered Users-pm+
 
fishinguy's Avatar
 
Join Date: Aug 05 2004
Age: 39
Posts: 6,230
Rep Power: 21486957
fishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Piratefishinguy has been promoted to Pirate
You should still have warranty on that one. I'd take it in.
fishinguy is online now   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 09-18-2020, 11:42 PM   #4
SKIPJACKSLAYER
Registered Users-pm+
 
Join Date: Nov 19 2013
Location: Flour Bluff
Age: 32
Posts: 1,111
Rep Power: 8603578
SKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to PirateSKIPJACKSLAYER has been promoted to Pirate
Quote:
Originally Posted by fishinguy View Post
You should still have warranty on that one. I'd take it in.
Well I checked it out and it still had 12+V power going into the pump, so i ruled out any sensor issue. He took it to Huff’s Marine And no joke they took it in on Thursday, replaced the motor on the pump under warranty, and handed it back over to him today. That’s some awesome service right there amigos
SKIPJACKSLAYER is offline   Reply With Quote Quick reply to this message
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 2CoolFishing forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 07:44 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2019
© 2013 Noreast Media, LLC | Terms of Service | Contact Us | Advertise