2007 silverado diesel AC question - 2CoolFishing
Home  |  Contact Us  |  Advertise   |   Follow:
Go Back   2CoolFishing > General Interest Forums > Trucks/Towing/Trailering Forum
Register FAQ Social Groups Calendar Mark Forums Read

Reply
 
Thread Tools Display Modes
Old 08-17-2019, 08:39 AM   #1
redduck
Registered Users-pm+
 
Join Date: Jul 26 2006
Age: 75
Posts: 4,610
Rep Power: 21484252
redduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirate
2007 silverado diesel AC question

For the last couple of weeks my AC will be blowing ice cold then for a few seconds or couple minutes it stops cooling then starts blowing cold air again. What are possible problems.
redduck is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-24-2019, 01:23 PM   #2
hurricane matt
Registered Users-pm+
 
hurricane matt's Avatar
 
Join Date: Apr 11 2017
Age: 43
Posts: 1,467
Rep Power: 11395994
hurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Pirate
Quote:
Originally Posted by redduck View Post
For the last couple of weeks my AC will be blowing ice cold then for a few seconds or couple minutes it stops cooling then starts blowing cold air again. What are possible problems.
Mine does same thing. Control module, there is a reset procedure.

Sent from my FRD-L14 using Tapatalk
hurricane matt is offline   Reply With Quote Quick reply to this message
Old 08-24-2019, 03:05 PM   #3
snapperlicious
Registered Users-pm+
 
snapperlicious's Avatar
 
Join Date: Aug 11 2009
Location: Tomball, Tx Matagorda, Tx
Age: 36
Posts: 3,801
Rep Power: 21482331
snapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Piratesnapperlicious has been promoted to Pirate
Is it on one side or both sides when it does it?
snapperlicious is offline   Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Old 08-25-2019, 07:59 AM   #4
ibtbone
John 3:16
 
Join Date: Oct 07 2013
Location: 77318
Age: 47
Posts: 1,183
Rep Power: 13612347
ibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirateibtbone has been promoted to Pirate
Low refrigerant charge is one possibility.


Sent from my iPhone using Tapatalk
ibtbone is offline   Reply With Quote Quick reply to this message
Old 08-26-2019, 09:08 AM   #5
On The Hook
Maker of custom TX numbers & wraps
 
On The Hook's Avatar
 
Join Date: Feb 23 2009
Location: South Texas
Age: 49
Posts: 3,624
Rep Power: 21482323
On The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to PirateOn The Hook has been promoted to Pirate
Does the fan still blow air when the a/c stops being cold? When the cold stops, is the compressor clutch still engaged and turning? These details will help narrow down the possible list of problems.
On The Hook is offline   Reply With Quote Quick reply to this message
Old 08-26-2019, 01:39 PM   #6
dk2429
Jeremiah 29:11
 
dk2429's Avatar
 
Join Date: Mar 27 2015
Location: Pearland/Galveston
Posts: 4,633
Rep Power: 21481109
dk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Piratedk2429 has been promoted to Pirate
Most likely low on refrigerant. Just go to a parts store and get some R134A refrigerant and add some if the gauge shows low.

If not, the compressor clutch could start to be on its way out, or your relay under the hood is acting wonky.
dk2429 is online now   Reply With Quote Quick reply to this message
Old 08-26-2019, 03:27 PM   #7
redduck
Registered Users-pm+
 
Join Date: Jul 26 2006
Age: 75
Posts: 4,610
Rep Power: 21484252
redduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirate
It stops cooling on both sides and air blower is still full force. Only lasts a minute or two. Since it does not last long I have been unable to see if clutch is working. It is super cold when working. I just wanted to get some idea of how to fix If it is a do it yourself project. Thanks for the comments.
redduck is offline   Reply With Quote Quick reply to this message
Old 08-29-2019, 05:36 PM   #8
redduck
Registered Users-pm+
 
Join Date: Jul 26 2006
Age: 75
Posts: 4,610
Rep Power: 21484252
redduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirate
The AC finally stopped cooling long enough for me to pull over and look under hood. The AC clutch was not turning. I took out my universal master tool (hammer) and tapped the clutch assembly. It immediately started turning and cold air began blowing. I recon that is the problem. Anyone know if this requires special tools like hub puller.
redduck is offline   Reply With Quote Quick reply to this message
Old 09-11-2019, 09:09 AM   #9
redduck
Registered Users-pm+
 
Join Date: Jul 26 2006
Age: 75
Posts: 4,610
Rep Power: 21484252
redduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirateredduck has been promoted to Pirate
Bought a clutch assembly online and installed. Works fine. Thanks for the help folks.
redduck is offline   Reply With Quote Quick reply to this message
Old 09-14-2019, 04:41 PM   #10
hurricane matt
Registered Users-pm+
 
hurricane matt's Avatar
 
Join Date: Apr 11 2017
Age: 43
Posts: 1,467
Rep Power: 11395994
hurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Piratehurricane matt has been promoted to Pirate
Quote:
Originally Posted by hurricane matt View Post
Mine does same thing. Control module, there is a reset procedure.

Sent from my FRD-L14 using Tapatalk
Actually blender actuator was the culprit. 30 dollar fix. Driver side would.get stupid and blow hot.

Sent from my Pixel 3 using Tapatalk
hurricane matt is offline   Reply With Quote Quick reply to this message
Reply

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 2CoolFishing forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 10:40 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2019
© 2013 Noreast Media, LLC | Terms of Service | Contact Us | Advertise