2007 Ford F150 5.4lt 4WD - 2CoolFishing
Home  |  Contact Us  |  Advertise   |   Follow:
Go Back   2CoolFishing > General Interest Forums > Trucks/Towing/Trailering Forum
Register FAQ Social Groups Calendar Mark Forums Read

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 11-03-2018, 05:26 PM   #1
Cozumel Annie
Registered Users-pm+
 
Cozumel Annie's Avatar
 
Join Date: Jan 13 2018
Posts: 100
Rep Power: 1825853
Cozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to PirateCozumel Annie has been promoted to Pirate
2007 Ford F150 5.4lt 4WD

Bought a rebuilt engine from Thunderbolt about 2 years ago and to date I've only put about 750 miles on it. I crank if over at least once a week and drive and once per month drive to the farm. Yesterday at idle after driving for a few minutes I noticed it was idling rough like it was misfiring? Engine light came on soon after so I plugged it in and received the following code: P0303. Looked that up and my gut told me I was right, but there were several other options dealing with O2 sensor, coils, catalytic converter, etc.... I had a half a tank of gas so filled up with 93 octane put in a fuel additive and the problem went away, but light still on. Disconnected battery to reset engine light. My question is do you think it's OK to drive for a bit to see what happens? Do you think I'm going to cause more issues?

Thanks for any advice or help you can give. Thank you.
Cozumel Annie is offline   Reply With Quote
 

Bookmarks

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the 2CoolFishing forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Ford F150 5.4L No oil pressure POCsaltdog TTMB 23 12-18-2015 04:57 PM
2007 Ford F150 5.4L No oil pressure POCsaltdog Hunting Board 5 12-08-2015 12:19 PM
Ford F150 THH TTMB 32 04-25-2013 06:29 PM


All times are GMT -5. The time now is 04:03 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
Resources saved on this page: MySQL 15.00%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.
Copyright 2019
© 2013 Noreast Media, LLC | Terms of Service | Contact Us | Advertise