2CoolFishing - View Single Post - Bad tires or service?
View Single Post
Old 01-13-2021, 11:38 AM   #6
bcoastal
Registered Users-pm+
 
Join Date: Aug 08 2012
Location: Galveston
Posts: 447
Rep Power: 1108828
bcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Piratebcoastal has been promoted to Pirate
Quote:
Originally Posted by TroutDaddy View Post
I have never heard much good things about the Atturo brand tires, especially if they are a mud tire. I watched a buddy wear out a set in under 10k miles when everything was good with his alignment and suspension. Cheap tires are never a good idea. Just my opinion. Not trying to hate on the brand. Did they replace all the bushings when you had the front end rebuilt?


Sent from my iPhone using Tapatalk
Yes bushing, tie rods, all new front end. I took it back to the shop and they rechecked the alignment and gave me a printout of specs to give to the tire shop.

Truck pulls to the left all the time.

I didn't know the tires had that bad of reputation. I looked online after the sale man told me about them and didnt find any bad stuff... guess I didnt look hard enough.

Still seems iffy to me that a big name tire store would sell something that pulls.
bcoastal is offline   Reply With Quote