2CoolFishing - Reply to Topic
Home  |  Contact Us  |  Advertise   |   Follow:

Go Back   2CoolFishing > General Interest Forums > Trucks/Towing/Trailering Forum > trying to get some insight ...

Thread: trying to get some insight ... Reply to Thread
Title:
  
Message:
Post Icons
You may choose an icon for your message from the following list:
 
 
 
 
 
 
 
 
 
 

Register Now

In order to be able to post messages on the 2CoolFishing forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in


Additional Options
Miscellaneous Options

Topic Review (Newest First)
02-28-2019 10:39 PM
acoastalbender Thanks for your thoughts ...sgrem on non starts there is no sound coming from anywhere you would expect and the only thing following script are the normal dash lights, no buzzing whirring or other sounds ... bw it's the 6.2 v8

With the sort of electronics installed in vehicles these days I was thinking maybe if the battery was even just a little 'tired' or marginal it might cause something odd like this ... in any case it'll have to wait til Monday or later as I got some important things going on the next few days ... hope it doesn't let me down
.
02-28-2019 05:44 PM
bwguardian On a 2015, I doubt it's the starter. It could be the starter solenoid, fuel pump and/or filter, etc....but need more information...probably something simple. Which power plant is it?
02-28-2019 01:03 PM
sgrem What is it doing on non start?
Clicking? Starter or battery or battery cables.
Or turn key and nothing at all? Maybe the key tumbler in the dash.
Dragging making the starter really work hard? Starter or battery or battery cables.

Todays starters are head and shoulders better equipment then the old school starters. I doubt it has any kind of dead spot.

Sounds like it is in your key or key tumbler.
02-28-2019 12:45 PM
acoastalbender
trying to get some insight ...

... into a problem before taking it to a dealer ...

Got a F250 gasser ('15) that just recently started not starting with the 1st key turn ... all the usual pre-ignition lights and warnings come on but when you turn the key ... nothing ... it actually did it once about 2 months ago but I dismissed it as something I did since it started right up on the 2nd turn ... couple of weeks ago it took 3 or 4 turns and yesterday it took probably a dozen turns to get it to crank ... is it as simple as needing a new battery or could there be a dead spot on the starter? Anyone run into something like this before? Thanks for any ideas or advise you might have ...
.

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -5. The time now is 08:36 PM.


Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
Resources saved on this page: MySQL 15.79%
vBulletin Optimisation provided by vB Optimise (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.
Copyright 2019
© 2013 Noreast Media, LLC | Terms of Service | Contact Us | Advertise