2 Cool Fishing Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
162 Posts
Discussion Starter · #1 ·
On the way home from fishing tonight the parking lights on my trailer both went out at the same time. Still have brake lights and turn signals. Checked/cleaned all connections. Checked/cleaned and re-attached ground wire. Traced wires to check for exposure. Made sure nuts and the back of the lights were tight and dug in. I never usually have problems figuring out what is wrong with my trailer lights, but I haven't been able to solve this one. What would cause me to lose both at the same time. By the way, the parking lights on the truck still work so it's not a fuse thing. Thanks for any input.
 

·
Registered Somewhere
Joined
·
5,635 Posts
If you have a Chevrolet. There are seperate fuses for the trailer harness and you blew the running lights fuse to the harness.
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #3 ·
Yes it's a chevy

Thanks for the reply. I did a search on this forum and came across this info. I'm working on that now. This is my first Chevy, and was not aware of this. Thanks.
 

·
Registered
Joined
·
162 Posts
Discussion Starter · #4 ·
problem solved

Thanks grayfish. Fixed in 5 mins. Wish I would have known this before I checked everything else. On all my previous vehicles if you blew the fuse you lost the parking lights on the truck also. I knew there was something weird about them both going out at the same time. I've fixed a lot of ground problems, and I knew that wasn't it. I guess I should have been able to figure this on my own. Thanks for the promt reply.
 
1 - 6 of 6 Posts
Top