2 Cool Fishing Forum banner

1 - 4 of 4 Posts

·
Speckle-Belly
Joined
·
245 Posts
Discussion Starter · #1 ·
i have a 2001 johnson ocean pro 115 and it seems the other day the tilt/trim going down just stopped working the up works fine just nothing going down. any suggestions on what i need to do to fix this problem
 

·
Registered
Joined
·
1,607 Posts
Not sure on your model, but I have a 1993 Erude and the usual problem is the relays. On mine, they are under the motor cowling on the top, front of the motor. there are two of them. Try swapping them and see if it works in the other direction. If it does, you found your problem. You can get aftermarket ones for about $8, OEM is around $30-40 I think.

Dave
 

·
Registered
Joined
·
1,704 Posts
yes try swaping the relays on the top port side front of the engine and see if it works, only the other way, if so a bad relay, the tilt limit switch may have messed up and can by pass it by tracing the wires two blue ones behind the air silencer cover and plugging the two from the relay package back into each other, and by pass the limit switch.
 

·
two of my favorites
Joined
·
1,243 Posts
PDP

If you don't find the problem in the relays, unplug the tilt trim cables at the power distribution panel and check to see if one of the tabs on the panel is loose. I have a 1999 175 FICHT that suffered solder fatigue on both tilt trim tabs. I just took the panel off the motor, removed the circuit board from the plastic cover and re-soldered the tabs on the circuit board. Good as new! Of course this was after I replaced the tilt trim motor to no avail. These PDP's are notorious for solder fatigue after they get several years old.

Use ATV silicone to re-seal the cover when re-assembling.
 
1 - 4 of 4 Posts
Top