2 Cool Fishing Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
822 Posts
Discussion Starter · #1 ·
Any tricks to get the speedometer to work?? I had the standard guages then switched to the Digital Yamaha guages, tried cleaning out the pin hole on the motor a couple of times still no success!!

Any additional thoughts??
 

·
Texas Aggie Fisherman
Joined
·
3,011 Posts
The "arm" mounted to the bottom of the boat is sitting correctly, right? A few times we've had our work it's way up due to the straps in the lift or something. When it does that, it won't ready anything. The simple solution was to push it back down. That's about the only problem I've ever had with one.
 

·
Registered
Joined
·
2,130 Posts
Trace the tube for a pinched spot. If all good then blow a little air into the tube fitting on the back of the speedo, DO NOT HOLD AIR GUN AGAINST THE FITTING, you could damage the diapham. Hold it 1-2" away and pass it over the hole, don't give it full pressure. The key switch will have to be on for this.
 

·
Registered Somewhere
Joined
·
5,633 Posts
Have you had water pump work done lately? On Yamaha's you have to disconnect the speedometer pick up hose to drop the lower unit. At least two things can happen. Someone forgot to reconnct the hose or maybe the broke or bent the plastic fitting inside the lower unit that goes to the pickup when reassembling the lower unit to the engine,

Of couse it could be just stopped up.

Did it work before you change guages?
 
1 - 6 of 6 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top