2 Cool Fishing Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3,926 Posts
Discussion Starter · #1 ·
IBM T40 Laptop, Windows 2000

Device manager shows an unknown PCI Device, cannot locate drivers for it, every device on the laptop has been accounted for. WHAT IS THIS DEVICE it is driving me crazy.......?????????
 

·
Premium Member
Joined
·
40,476 Posts
is it yellow?

you could always remove from the device manager and reboot. Then it should give you an idea what it is when it is detected and looking for drivers.
 

·
Registered
Joined
·
150 Posts
Try to install the drivers with the Microsoft Windows update rather than cd/floppy etc. I've had it amazinly work before. It will be some system chipset driver or usb driver(even though your usb is working)
 

·
Registered
Joined
·
150 Posts
You can give it a shot for sure. I've never worked on many T series mostly the a and x series and i've seen the unknown device be something along the lines of a pci bridge to usb or something. It's been a while. One of those hardware architectur thingys I don't get.
 

·
Banned
Joined
·
9,560 Posts
Just got back in from Vail, so I've been out of touch for a while. I would suggest the same thing Bill said...remove the device and see if Windows tries to reinstall anything when you reboot. Likely it is an old modem or other PCI device that has been removed from the machine, or a bridge like Bill said. Either way, removing the device from the Device Manager will not hurt anything since it isn't detected anyway.
 
1 - 6 of 6 Posts
Top