2 Cool Fishing Forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
I have a CMC PL 65 jack plate and when I took my boat out this morning the jack plate worked like normal, then when I got to the house it did not work. When I pressed the switch to jack it up, nothing happened. No noises or anything. I checked the tilt and trim and the lights to make sure the battery is good and it is. Any help is greatly appreciated. Thanks in advance.
 

·
Registered
Joined
·
220 Posts
Relay, fuse, or actuator. First would be to check the connections though.

Low on fluid the motor would still run. Since you have nothing I would check electrical items before opening up the fluid system
 

·
Registered
Joined
·
153 Posts
Check the inline fuse or breaker on the hot side from the battery. Typically a small box, it has a reset button.

Wiggle ground cable while trying to raise or lower the plate.

Lastly do you hear or feel the relays clicking when you move the switch?

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #5 ·
Any idea where the fuse would be at? There is no clicking or anything. I have a battery selector switch and there is no difference between when it is off and when it has a battery selected.
 

·
Registered
Joined
·
153 Posts
On the main power wire going to the main relay there should be a breaker switch. See pic below. You can test each side to see if it is blown or not. This part usually comes with the wiring harness.


Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
153 Posts
If you have voltage across the breaker pull the ground wire, clean it well and re-install. I had a loose ground that was a mystery. You could wiggle the wires and it would work then stop. I re-crimped the ground wires and all good.

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #12 ·
Hood Automotive exterior Electrical wiring Motor vehicle Cable

Is it possible it could be under the cowling? I was doing some looking and couldn’t find it then I thought to check under the cowling because it appeared the wires go in the cowling and around to the Jack plate. I found this. I bought this boat in July and this is the first time I’ve had Jack plate problems with it. Hope everyone had a good thanksgiving.
 

·
Registered
Joined
·
153 Posts
Yes that is it. Put a volt meter on one leg with the other on ground. If you have voltage, then do the same thing on the other leg. If one leg has no voltage it is tripped and must be reset. The relays are under the cowling too. You should hear them click when you go up or down.

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #14 ·
Alright so I opened that in-line fuse (purple wire behind circuit breaker) and it was connected and looked good. I then tested that circuit breaker w a multimeter and both legs had power. I then tested the switch w a multimeter and it had power too. I cleaned the relays too and they don’t have that corrosion on it anymore. Still not working.
 

·
Registered
Joined
·
153 Posts
The only other thing I can recommend is taking the wires off your ground post and make sure everything is clean, tight, and no loose crimping. If your not hearing the relays click when you move the switch it has to be related to the ground.

Sent from my ONEPLUS A6013 using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #17 · (Edited)
Today I tested the relays with a multimeter and only 1 on each had 12+, 1 had 8 and another had .25. Could this be my problem? I hear no clicking when I turn the switch to raise or lower the Jack plate. If so, how do I fix it? I have attached pictures. Also, would the ground run out of the circuit breaker? I am having trouble locating where the ground connects under the cowling.
Motor vehicle Plant Audio equipment Gas Machine

Cameras & optics Plant Gadget Camera accessory Audio equipment

Audio equipment Reflex camera Cameras & optics Gadget Motor vehicle

Reflex camera Camera accessory Digital camera Cameras & optics Gadget
 

·
Registered
Joined
·
10 Posts
Discussion Starter · #18 ·
Was rereading this thread and realized I never switched the relays. I switched the relays and it worked (not 100%, but I got it to move up and down lol) and I heard clicking.
 
1 - 18 of 18 Posts
Top