2 Cool Fishing Forum banner
1 - 8 of 8 Posts

·
Registered
Joined
·
226 Posts
Discussion Starter · #1 ·
I recently used my Curado 200 while surf fishing and it got wet a few times so I rinsed it off with freshwater when I got, took the side off and the spool and put a drop or 2 of abu garcia reel oil on each metal part. When I put it back together it doesn't reel nearly as easy. Did I mess something up? I only took 3 pieces off.
 

·
Registered
Joined
·
2,729 Posts
I'm not familiar with the Abu Garcia reel oil but if it's a thicker oil meant for other parts and you put it on the bearings that can slow down a reel significantly. Oil for bearings is thin and very light weight oil like rocket fuel, rem oil, super lube, etc... You may have also tightened the cast control cap to tight if you took it off. There are several other reasons but this is a start of things to look at.
 

·
Registered
Joined
·
1,288 Posts
Make sure that the line is not caught in the spool. That is a very easy mistake to make when you take the spool out.
 

·
fish control my brain
Joined
·
7,737 Posts
You most likley got fine sand and salt in your reel thru the shaft


Take your spool out and wipe the reel down with a cloth that was reel magic or corrision X sprayed ( ON the RAG )

Wipe dry the shaft of the spool
and put one drop of oil on that bearing and clean with a q-tip

If you have contunius problems you got something internaly wrong and need to have it serviced.
 

·
Registered
Joined
·
226 Posts
Discussion Starter · #6 ·
Fishaholic said:
Make sure that the line is not caught in the spool. That is a very easy mistake to make when you take the spool out.
alright, I feel like an idiot! There was a very small piece of line that was getting caught when I put the spool back on...I thought I had taped it all down. Reel works fine again, great webpage on how to clean and maintain this reel by the way. Thanks for everyone's help!
 

·
Registered
Joined
·
1,288 Posts
Alright i am glad i could help. Been there done that a few times thought that could have been it.
 

·
Registered
Joined
·
1,050 Posts
I usually put a small rubber band on the spool to hold the line in. After I see that it's working O.K., I cut the rubber band off.
 
1 - 8 of 8 Posts
Top