2 Cool Fishing Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
985 Posts
Discussion Starter · #1 ·
Have a 2016 F-250 Lariat Diesel with the upfitter switches. I wired in a light bar 4 years ago and all has worked fine until a couple months ago. The kids were turning it on and off rapidly and I assume they blew a fuse or something. I have searched over the internet and checked some fuses but all fuses seem good to me. I might be checking the wrong fuses but does anybody know for sure which fuse it is? The light bar is wired into upfitter switch #1.

I disconnected the wires at the light bar (I wired it with disconnects so I could remove it easily if needed) and hooked up the light bar directly to a 9v battery and the light bar works so that is not the problem. I threw a volt meter on the end of the wires I ran and I have no power. The little power indicator light on the upfitter switch comes on when I turn it on like it always did.

What am I missing? Are there any relays or something that I don't know about? Don't really want to re-wire it since I remember it being a major pain in the rear since Ford leaves you 2" of wire to work with, but i will if I have to.

Thanks in advance.
 

·
archTech
Joined
·
8,579 Posts
I would think the light bar came with its own inline fuse. I would also rule out the switch...given the way it was operated when you started having issues...by swapping it with a known good switch probably right next to the one you are having issues with...
 

·
Registered
Joined
·
1,568 Posts
Mine are in the engine compartment fuse box.

uplifter switch fuses for #1 & #2, engine compartment fuse box, fuse #94 & #95.
 

·
Registered
Joined
·
985 Posts
Discussion Starter · #4 ·
yup.....that was the diagram i was working off of. All the fuses looked good. guess i will just re-wire to switch #2
 
1 - 4 of 4 Posts
Top